Page 1 of 2

New install on Linux Mint will not run

Posted: Fri May 22, 2020 9:22 am
by n_spect_r
Bought the pro last year, been using it every day and I like it. Just made some changes and switched from Linux Lite to Mint. Installation seems to be OK but it will not start. Tried to start from a terminal and I get Command not found. Missing some dependency? Thanks.

Re: New install on Linux Mint will not run

Posted: Fri May 22, 2020 3:45 pm
by andrew
Which package did you download? What's your distribution version? 32bit or 64bit?

Some general information:
- There are different packages of QCAD for older systems (look for "Qt 4") as well as for newer systems with Wayland (look for "Qt 5.13").
- Check for missing dependencies using:
cd /path/to/qcad
LD_LIBRARY_PATH=. ldd ./qcad-bin

Re: New install on Linux Mint will not run

Posted: Sat May 23, 2020 11:09 am
by petevick
I recently installed Qcad Pro on Linux Mint 19.3 Cinnamon with no problem at all, maybe you need to just reinstall Qcad. FYI, when you install the .run package in the command window (you have to change the Execute permission of the file to allow executing as a program), it will create a folder in Home called "opt" under that is the "qcad-3.24.3-pro-linux-x86_64" folder with the qcad executable in the root of that folder.

Re: New install on Linux Mint will not run

Posted: Sat May 23, 2020 11:21 am
by n_spect_r
It is installed on the latest release of Cinnamon, and I have tried going to the opt/qcad... folder and running from a terminal in the folder. I get unknown command error.

As to other questions. 64 bit, Qcadcam-3.23.0-pro-linux-x86_64, the package manager shows several instances of QT5, there are some QT4 listed but I don't believe they are installed. I will check dependencies when I get to work. Thank you

Re: New install on Linux Mint will not run

Posted: Sat May 23, 2020 12:31 pm
by n_spect_r
Ran LD_LIBRARY_PATH=. ldd ./qcad-bin in the folder,

~/opt/qcadcam-3.23.0-pro-linux-x86_64$ LD_LIBRARY_PATH=. ldd ./qcad-bin
not a dynamic executable
:~/opt/qcadcam-3.23.0-pro-linux-x86_64$

Re: New install on Linux Mint will not run

Posted: Sat May 23, 2020 12:35 pm
by petevick
n_spect_r wrote:
Sat May 23, 2020 12:31 pm
Ran LD_LIBRARY_PATH=. ldd ./qcad-bin in the folder,

~/opt/qcadcam-3.23.0-pro-linux-x86_64$ LD_LIBRARY_PATH=. ldd ./qcad-bin
not a dynamic executable
:~/opt/qcadcam-3.23.0-pro-linux-x86_64$
the executable is qcad, no file extension

Re: New install on Linux Mint will not run

Posted: Sat May 23, 2020 12:35 pm
by n_spect_r
This is what the terminal shows on install.

Verifying archive integrity... All good.
Uncompressing QCAD...........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
QCAD Setup...
Making dir /home/dc/opt/qcadcam-3.23.0-pro-linux-x86_64...
Copying files...
Invoking postinstall.sh...
Installing mimetypes...
Installing mimetype icons...
Installing desktop menu entries...
Installing desktop icon...
Creating uninstall script...
Setting executable flag...
QCAD Setup finished.
[email protected]:~/Downloads$

Re: New install on Linux Mint will not run

Posted: Sat May 23, 2020 12:38 pm
by n_spect_r
I ran the text that you originally posted, it shows the .bin. Ran again without the .bin and I get the same thing.

Re: New install on Linux Mint will not run

Posted: Sat May 23, 2020 12:42 pm
by petevick
n_spect_r wrote:
Sat May 23, 2020 12:38 pm
I ran the text that you originally posted, it shows the .bin. Ran again without the .bin and I get the same thing.
there should be a file called just qcad no extension, there is also a file called qcad.bin, it's the one without an extension you should use

Re: New install on Linux Mint will not run

Posted: Sat May 23, 2020 12:55 pm
by n_spect_r
I tried deleting all files, and reinstalling from another copy. Still would not start from desktop. Tried from terminal.

./qcad
./qcad: line 9: ./qcad-bin: cannot execute binary file: Exec format error

QCAD has unexpectedly quit.

Please use the offscreen platform plugin for headless systems
(without a running X11 server):
./qcad -platform offscreen

In addition, you might have to override the default Qt style
to prevent the loading of a native desktop style (such as GTK):
./qcad -style plastique

Re: New install on Linux Mint will not run

Posted: Sat May 23, 2020 3:04 pm
by n_spect_r
Are we now all stumped?

Re: New install on Linux Mint will not run

Posted: Sat May 23, 2020 3:11 pm
by petevick
n_spect_r wrote:
Sat May 23, 2020 3:04 pm
Are we now all stumped?
To be honest, I'm a bit confused. Firstly, can you confirm which file you are using to launch Qcad

Re: New install on Linux Mint will not run

Posted: Sat May 23, 2020 3:20 pm
by petevick
I launch it from a desktop launcher with the following in the command field -

Code: Select all

/home/p****e/opt/qcad-3.24.3-pro-linux-x86_64/qcad

Re: New install on Linux Mint will not run

Posted: Sat May 23, 2020 3:41 pm
by petevick
actually, I've just read that if you installed Qcad using the .run file, a desktop launcher should be added as part of the install :?:

Re: New install on Linux Mint will not run

Posted: Sat May 23, 2020 3:47 pm
by n_spect_r
If I try from the desktop launcher nothing happens. This is the path in the launcher
"/home/.../opt/qcadcam-3.23.0-pro-linux-x86_64/qcad" %F


I just tried installing the same program on a Linux Peppermint system and it works.
Maybe the %F should not be there but it's there, but it is on Peppermint and works.

Typically, when there are dependency issues, launching a program from a terminal will give some insight.
With that in mind, I've tried launching from a terminal in the installation directory. BTW, doing that works on the Peppermint system.