QCAD Application Font Looks Odd

If you are having problems with QCAD, post here. Please report bugs through our Bug Tracker instead.

Always attach your original DXF or DWG file and mentions your QCAD version and the platform you are on.

Moderator: andrew

Forum rules
Always indicate Operating system, QCAD version
Attach Drawing files, Screenshots
Post Reply
dklann
Registered Member
Posts: 2
Joined: Thu May 16, 2019 5:28 pm

QCAD Application Font Looks Odd

Post by dklann » Thu May 16, 2019 5:47 pm

Hi! I am using QCAD version 3.22.0 on Arch Linux, with the GNOME 3.32 desktop. Previous versions have had this problem as well.

The application font (menu text, dialog boxes, etc.) appears messed up to me. Actual drawing text appears fine, and text in other Qt applications looks normal. See the attached screenshot for an example.

I have deleted $HOME/.config/QCAD/QCAD3.conf and still the application font looks odd.

I would appreciate learning how to make the QCAD application font look "normal".

Thanks for your thoughts!

David
Attachments
Screenshot from 2019-05-16 11-34-11.png
Screenshot from 2019-05-16 11-34-11.png (64.15 KiB) Viewed 283 times

User avatar
andrew
Site Admin
Posts: 6158
Joined: Fri Mar 30, 2007 6:07 am

Re: QCAD Application Font Looks Odd

Post by andrew » Thu May 16, 2019 6:15 pm

This could be any number of things to do with X11, Qt, your window manager, etc.

This is what I'd try first:
- Move all libQt5* files from your QCAD directory into a temporary directory. QCAD comes with its own Qt libraries. By doing this, you can use your systems Qt libraries instead. This might fix the problem or it might mean you can't start QCAD anymore at all...

You also might want to ask in the ArchLinux forum. This thread seems at least related and suggests a fix in /etc/fonts/local.conf:
https://bbs.archlinux.org/viewtopic.php ... 1#p1350501

dklann
Registered Member
Posts: 2
Joined: Thu May 16, 2019 5:28 pm

[SOLVED] QCAD Font Hinting on Linux (was "QCAD Application Font Looks Odd")

Post by dklann » Fri May 17, 2019 8:32 pm

Thanks for your reply @andrew. It was not (directly) either of your suggestions that solved my font display issue. But ...

You were correct: moving the QT5 libraries out of the QCAD runtime directory caused QCAD to not start. The error I received was:
./qcad-bin: relocation error: $HOME/opt/qcad-3.22.0-pro-linux-x86_64/plugins/script/libqtscript_uitools.so: symbol _ZdlPvm version Qt_5 not defined in file libQt5Core.so.5 with link time reference
(substitute your home directory for $HOME)

I looked through the Arch forum post you linked to and that gave me more font-related things to look for.

Using strace(1) to launch QCAD from the command line, I looked for all references to "font", and found that QCAD was opening
$HOME/.config/fontconfig/fonts.conf

I simply moved that file out of the way and QCAD's fonts look fine now. Maybe someone with more knowledge or experience with font configuration could adjust the settings in that file and leave it in place...

Thanks again for your suggestions!

Here is the entire contents of the file from my system for my future self, and for others who might encounter this:

Code: Select all

<?xml version="1.0"?><!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
 <match target="font">
  <edit mode="assign" name="rgba">
   <const>vrgb</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hinting">
   <bool>true</bool>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hintstyle">
   <const>hintfull</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="antialias">
   <bool>true</bool>
  </edit>
 </match>
</fontconfig>

Post Reply

Return to “QCAD Troubleshooting and Problems”