QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask Type  ascSeveritySummaryStatusProgress
1919QCAD (main)Bug ReportVery LowWrong order XY(Z) for Ordinate Dimension in property ed...Assigned
0%
Task Description

Win7pro Qcad Pro 3.22.1.2

In property editor
properties of an Ordinate Dimension

Without Show Z
DefPoint is displayed in order YX?

With Show Z
Origin is displayed in order XZY?
DefPoint is displayed in order YZX?
LeaderEndPoint is displayed in order ZXY?

Regards

1443QCAD (main)Bug ReportVery LowView > Status Bar remains uncheckedAssigned
0%
Task Description

Status Bar menu remains unchecked even it is toggled on or off

1905QCAD (main)Bug ReportVery LowView > Property Editor: Changing attribute of block cha...Assigned
0%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=6367#p23947

705QCAD (main)Bug ReportLowVerwaltung Library Resourcen und Favoriten ....Assigned
0%
Task Description

Ob dies ein Feature Request oder ein Bugreport ist weiß ich nicht ....

Hier meine Gedanken ....

In den Application Preferences kann ich mehrere Library Sources vorgeben. Ich habe eine auf dem HD und eine auf einen USB angegeben.

Wenn ich nun QCad auf der HD ausführe habe ich beide Ressourcen zur Verfügung. Schön! Natürlich habe ich auch im Library Browser meine Favoriten von beiden Ressourcen angegeben.

Wenn ich nun aber den USB entferne zeigt mir der Library Browser immer noch beide Resorcen als Name an - schalte ich nun um auf die USB Resource bekomme ich keinerlei Hinweis das diese momentan nicht zur Verfügung steht. Es passiert einfach NIX ;-) Es wäre schön wenn ich hier eine “Nicht verfügbar” Meldung bekommen würde.

Wenn ich nun meine Trotteligkeit bemerke und den USB wieder einstecke habe ich logischerweise wieder meine Library zur Verfügung ..... nur die auf den USB Stick verweisenden Favoriten sind auf Nimmerwiedersehen verschwunden. Die auf dem HD bleiben erhalten!

OK - um es ganz rund zu machen ein anderes Szenarios in “Steno”:
QCad Start vom USB - > Library Favoriten anlegen auf USB Library - > QCad schließen - > USB entfernen → QCad auf HD starten - > Library Favoriten auf USB sind verschwunden - > QCad HD schließen - > USB einstecken und QCad von USB starten = Favoriten auf USB bleiben verloren!

Wäre es hier nicht möglich die Favoriten Information dem USB mit auf dem Weg zu geben? Wenn ich eine Favoriten Auswahl auf dem USB nicht kontrollieren kann macht diese Möglichkeit kaum Sinn.

721QCAD (main)Bug ReportLowVertical dimensions imported as horizontal dimensionsAssigned
0%
Task Description

Vertical dimensions created with 3rd party applications are sometimes imported as horizontal dimensions with length 0. Changing the angle in the property editor fixes the problem.
Problem occurs in QCAD 2.2 and QCAD 3.0.

1936QCAD (main)Bug ReportLowver 3.23 not saving font informationAssigned
0%
Task Description

The attached file is not saving font preference.
All fonts on the online layer are reported as the standard font. If I highlight one or all of the text entities and change the font to something like Yu gothic light, the property page reports yu gothic light and the screen reflects the changed font.
If I save, close and reload, the fonts for all text is again “standard”.

So then I try to enter new text via the “A” draw text command icon. I select “Broadway.ttf” as the main font in the text entry dialog.
One word “Broadway” is entered as the text. it appears on the upper left of the screen as expected and the font name is Broadway in the property editor. If I look at the dxf file source there is a whole bunch of text styles.
I save and close the file, and then open it again. Now the word Broadway has changed to font name “standard” in the property editor and is very definitely not the Broadway.ttf font.

I am not the originator of the file, I am just trying to change the font. If I start a new file and enter new text the font saves just fine, so I am thinking it is a setting somewhere, but I am unable to find it.

We (me and my customers) use these files for engraving so exact font is critical.

1719QCAD (main)Bug ReportVery LowUndo on converted drawing leads to wrong label position...Assigned
0%
Task Description

Drawing converted from inch to mm - undo leads to wrong dim label position. I can fix that with “Reset Label position” but it would be nice if QCAD could to that in first place.

513TranslationBug ReportLowTranslation errorsAssigned
0%
Task Description

If you spot an error in the translated user interface of QCAD, please add a comment to this task or submit your translation at http://translate.qcad.org.
Thank you for your help!

Wenn Sie einen Fehler in der übersetzten Benutzeroberfläche von QCAD erkennen, fügen Sie bitte einen Kommentar zu diesem Report hinzu oder geben Sie Ihre Übersetzung ein unter http://translate.qcad.org.
Vielen Dank für Ihre Hilfe!

Si vous remarquez une erreur dans l’interface utilisateur traduite de QCAD, veuillez ajouter un commentaire à cette tâche ou soumettre votre traduction à http://translate.qcad.org.
Merci pour votre aide!

Si detecta un error en la interfaz de usuario traducida de QCAD, añada un comentario a esta tarea o envíe su traducción a http://translate.qcad.org.
Gracias por tu ayuda!

Se si rileva un errore nell’interfaccia utente tradotta di QCAD, si prega di aggiungere un commento a questo compito o di inviare la traduzione a http://translate.qcad.org.
Obrigado por sua ajuda!

Se você detectar um erro na interface de usuário traduzida do QCAD, adicione um comentário a esta tarefa ou envie sua tradução para http://translate.qcad.org.
Obrigado pela sua ajuda!

Als u een fout ziet in de vertaalde gebruikersinterface van QCAD, voeg dan een opmerking toe aan deze taak of stuur uw vertaling naar http://translate.qcad.org.
Bedankt voor uw hulp!

1912QCAD/CAMBug ReportLowTool Description ErrorAssigned
0%
Task Description

Hallo Andrew,

Testing the drill toolpath I find it hard to select the correct tool by a small bug

1961dwg2pdfBug ReportLowToo many drawings are missingAssigned
0%
Task Description

Hello, I found a bug.

Original file: 006–【武汉会展中心店】一层合用前室.dwg

Converted file: 006–【武汉会展中心店】一层合用前室.pdf

Command line: .\dwg2pdf.bat -f -a -recompute-dim -ltscale=1 -block=布局1 path

Bug description file: problem8.png

As you see. I use dwg2pdf to export the block named “布局1”. There are too many drawings missing.

864QCAD (main)Bug ReportLowTemplate Preview/Info doesn't shows the sheet orientati...Assigned
0%
Task Description

“Create New Drawing from Template” Browser can’t readout the Page orientation ...

1445QCAD (main)Bug ReportLowSwitching off grid scaling can break rulersAssigned
0%
Task Description

See also:
http://www.qcad.org/rsforum/viewtopic.php?f=32&t=4314

1924QCAD (main)Bug ReportLowSweepAngle = 0Assigned
0%
Task Description

Win7pro 32bit Wininstaller Qcadpro 3.23.0

Draw an arc.
Select the arc.
In Property Editor:
Set start angle to 135
Set end angle to 135

SweepAngle = */-360

edit the end angle and add “+360”, hit enter

SweepAngle = 0

An arc with zero sweep is a point.
A point is not an arc.
With the same start and end parameter an arc should have a sweep of +/-360.
As for entries by points or by angles.

Regards

1242QCAD (main)Bug ReportLowSVG import DPI box should use localized decimal separat...Assigned
0%
Task Description

I wanted to make it so, that SVG units translate 1:1 into CAD units; I use the German localized QCAD and entered 25,4 into the box with the wrong result, i.e. the same as 25; Entering 25.4 got me what I wanted: The question box needs the point and ignores the comma. Would be nice if it could use the localized separator.

736QCAD (main)Bug ReportLowsnap tool menu is shown before specifiv tool menuAssigned
0%
Task Description

When creating a new file, selecting the e. g. line tool at first opens the linemenu and the snap tool menu as expected. After clicking on the back button twice (going back to the main menu) and selecting the e. g. circle menu, the snap tool menu is shown instead of the circle menu. Instead the circle menu is shown after pressing the back button again.

This only happens when clicking on the back button, but with any tool menu seleected. Pressing escape to go back does not show this problem.

QCAD is running on Mac OS Mountain Lion.

1760QCAD (main)Bug ReportVery LowSelf-crossing polylines can't be cut twice at segment c...Assigned
0%
Task Description

Re-entering dividing problem from  FS#1757 

Divide the poly selecting near segment 1 at the segment crossing.
> A new node is inserted on the crossing and made start and end node.
Divide the poly again selecting near segment 2 at the segment crossing.
> no division appears to be done.

One can’t divide the second segment at the crossing

Presumed intended behaviour like  FS#1750 

Regards

523QCAD (main)Bug ReportLowSelection tool button in CAD tool bar shows line tools ...Assigned
0%
Task Description

The selection tool is not accessible:

Click on Selection Tool icon - left panel:

Left panel then shows line tool options.

Click “back” button at top of left panel:

Left panel then shows selection options.

Click an option icon:

Left panel then shows line tool options again.

700QCAD (main)Bug ReportLowSaved 'hatched' block loses hatching when using isometr...Assigned
0%
Task Description

Hatched block loses hatching when using isometric projection tool:
See -http://www.qcad.org/rsforum/viewtopic.php?f=32&p=7063#p7063

When manipulating a saved hatched block with the isometric tool it loses the hatching unless the block is exploded.

Is this normal behaviour here? or a bug?

1087QCAD (main)Bug ReportLowRuler ticks are not corresponding to the grid pointsAssigned
0%
Task Description

Ruler ticks are not corresponding to the grid points,
Ruler will completely disappear at a certain zoom level,

Settings:
Drawing unit: inch,
Grid settings: Grid 1, Meta Grid 12,
Dim Label Format: “Engineering, 0’-0.0”

see topic below:
http://www.qcad.org/rsforum/viewtopic.php?f=32&t=3014

1900QCAD (main)Bug ReportVery LowRemote shares initially not accessible.Assigned
0%
Task Description

My data files are stored on network shares (synology) with a GB link. QCAD Pro is run in Admin mode.

While in my Windows browser all remote shares are accessible (Green), in the QCAD file open menu they are initially shown as not accessible (Red). By accessing a specific drawing file in a remote share, the share will open and turn green.

Same behavior using ‘Open recent’. Always the message is given that the requested file does not exist, and the file is wiped from the ‘Recent Open’ list. Only if the share is first accessed through ‘Open’ with a random file, it will turn and a ‘recent open’ file for that share will open.

Drag and Drop from a remote share will never work.

733QCAD (main)Bug ReportLowQCAD Trial: batch tool dwg2bmp produces no outputAssigned
0%
Task Description

Some users are experiencing problems with dwg2bmp.

See forum at:
http://www.qcad.org/rsforum/viewtopic.php?f=32&t=2272&view=unread#unread

729QCAD (main)Bug ReportLowPreferences not stored on some installationsAssigned
0%
Task Description

Preferences not stored on some installations

See:
http://www.qcad.org/rsforum/viewtopic.php?f=33&t=2269&view=unread#unread

665QCAD (main)Bug ReportLowPossible printing error on Linux fedora 16?Assigned
0%
Task Description

On behalf of et76
Possible printing error using Linux 16 - needs further testing!
Please see topic: http://www.ribbonsoft.com/rsforum/viewtopic.php?f=12&t=2119

Au nom de et76
Erreur d’impression possible en utilisant Linux 16 - a besoin d’autres tests!
S’il vous plaît voir le sujet: http://www.ribbonsoft.com/rsforum/viewtopic.php?f=12&t=2119

753QCAD (main)Bug ReportLowPaste Preview confusing ....Assigned
0%
Task Description

If I paste something from the clipboard to a drawing the scales of dims are wrong in the preview.

It is difficult to place it right with a confusing preview of that what I have to place ... ;-)

641QCAD (main)Bug ReportLowNo warning is displayed when lengthen tool is used with...Assigned
0%
Task Description

Command ‘Lengthen LE’ will extend most arcs but not all (2 arcs in the attached drawing do not work)! There is no obvious reason for this from the users point of view.

1916QCAD (main)Bug ReportLowMoving an object in an angled viewport with mouse does ...Assigned
0%
Task Description

To reproduce

1. Select a new view-port in model-space
2. Select the appropriate paper-space
3. When the paper space opens change the angle of the viewport to 90 degrees
4. Place view-port in paper space
5. Select the view-port in paper-space by clicking it
6. Try to move the object itself in the view-port (by clicking the “top” dot) to the right by moving the mouse to the right while holding the left mouse-button.

Actual

The object in the viewport moves down vertically NOT to the right

Expected

The object moves to the right

(It seems mouse movement does not compensate for the rotated angle of the viewport)

Workaround

None, except compensate for the angle in your head and moving the mouse the “wrong” way when correcting the placement of objects in the view-port

948QCAD (main)Bug ReportLowmainwindow example segfaultsAssigned
0%
Task Description

As far as I can tell, it never worked.

#0  0x0000000000490527 in QFormInternal::domPropertyToVariant ()
No symbol table info available.
#1  0x000000000042aea9 in QFormInternal::QAbstractFormBuilder::toVariant ()
No symbol table info available.
#2  0x00000000004498a6 in QFormInternal::QFormBuilder::applyProperties ()
No symbol table info available.
#3  0x000000000042475f in QFormInternal::FormBuilderPrivate::applyProperties ()
No symbol table info available.
#4  0x000000000042e83b in QFormInternal::QAbstractFormBuilder::create ()
No symbol table info available.
#5  0x00000000004493c0 in QFormInternal::QFormBuilder::create ()
No symbol table info available.
#6  0x000000000042182e in QFormInternal::FormBuilderPrivate::create ()
No symbol table info available.
#7  0x000000000042fa37 in QFormInternal::QAbstractFormBuilder::create ()
No symbol table info available.
#8  0x00000000004225a2 in QFormInternal::FormBuilderPrivate::create ()
No symbol table info available.
#9  0x0000000815eed3d7 in QFormInternal::QAbstractFormBuilder::load ()
   from /usr/home/ice/w/qcad/qcad/plugins/script/libqtscript_uitools.so.1.0.0
No symbol table info available.
#10 0x0000000815ededad in QUiLoader::load () from /usr/home/ice/w/qcad/qcad/plugins/script/libqtscript_uitools.so.1.0.0
No symbol table info available.
#11 0x0000000815eda326 in qtscript_QUiLoader_prototype_call (context=0x813262240)
    at ../../generated_cpp/com_trolltech_qt_uitools/qtscript_QUiLoader.cpp:282
        _q_arg0 = (QIODevice *) 0x813fe5610
        _q_arg1 = (QWidget *) 0x813ffdcd0
        _q_result = (QWidget *) 0x8006e2c00
        _id = <value optimized out>
        _q_self = (QUiLoader *) 0x813f08d40
#12 0x0000000805fc9f78 in QScript::FunctionWrapper::proxyCall () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#13 0x0000000805ee418f in QTJSC::NativeFuncWrapper::operator() () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#14 0x0000000805eb93ee in QTJSC::Interpreter::privateExecute () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#15 0x0000000805ec1ccd in QTJSC::Interpreter::execute () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#16 0x0000000805ec1ff9 in QTJSC::Interpreter::execute () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#17 0x0000000805fa9743 in QScriptEnginePrivate::evaluateHelper () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#18 0x0000000805faabc6 in QScriptEngine::evaluate () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#19 0x0000000800ac5aae in RScriptHandlerEcma::eval (this=0x811f435e0, script=<value optimized out>, 
    fileName=<value optimized out>) at RScriptHandlerEcma.cpp:855
        err = {d_ptr = {d = 0x7fffffffcf50}}
#20 0x0000000800ac65c5 in RScriptHandlerEcma::doScript (this=0x811f435e0, scriptFile=@0x7fffffffd2f0, 
    arguments=<value optimized out>) at RScriptHandlerEcma.cpp:851
        fi = {d_ptr = {d = 0x813f94700}}
        globalObject = {d_ptr = {d = 0x813ff1240}}
        contents = {static null = {<No data fields>}, static shared_null = {ref = {_q_value = 3936}, alloc = 0, size = 0, 
    data = 0x809bb387a, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, 
  static shared_empty = {ref = {_q_value = 19}, alloc = 0, size = 0, data = 0x809bb389a, clean = 0, simpletext = 0, 
    righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, d = 0x811c11800, static codecForCStrings = 0x0}
#21 0x0000000000417d13 in MainWindow (this=0x7fffffffd4b0, parent=<value optimized out>) at MainWindow.cpp:99
No locals.
#22 0x0000000000416ad9 in main (argc=1, argv=<value optimized out>) at main.cpp:35
        app = <value optimized out>
        window = {<QMainWindow> = {<QWidget> = {<QObject> = {_vptr$QObject = 0x4992b0, static staticMetaObject = {d = {
            superdata = 0x0, stringdata = 0x809933ae0 "QObject", data = 0x809933b80, extradata = 0x809ba94c0}}, 
        static staticMetaObjectExtraData = {objects = 0x0, 
          static_metacall = 0x80985cd80 <QObject::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)>}, d_ptr = {
          d = 0x811d28600}, static staticQtMetaObject = {d = {superdata = 0x0, stringdata = 0x80993cc40 "Qt", 
            data = 0x809940560, extradata = 0x0}}}, <QPaintDevice> = {_vptr$QPaintDevice = 0x499478, painters = 0}, 
      static staticMetaObject = {d = {superdata = 0x809ba94e0, stringdata = 0x808e66be0 "QWidget", data = 0x808e670c0, 
          extradata = 0x809282360}}, static staticMetaObjectExtraData = {objects = 0x0, 
        static_metacall = 0x8087899a0 <QWidget::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)>}, 
      data = 0x811d28748}, static staticMetaObject = {d = {superdata = 0x809282380, stringdata = 0x808ec04c0 "QMainWindow", 
        data = 0x808ec0660, extradata = 0x8092abc60}}, static staticMetaObjectExtraData = {objects = 0x8092d1880, 
      static_metacall = 0x808e5aaf0 <QMainWindow::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)>}}, 
  documentInterface = 0x811d31600}
        ret = <value optimized out>
1462QCAD (main)Bug ReportLowMac Trackpad zoom gesture not working as expectedAssigned
0%
1 Task Description

Hi,

I am using mac version and I have annoying issue with trackpad.
I use qcad primary with my trackpad and under application preferences (Graphics View/Navigation), my setting is as follows.
Mouse wheel / two finger swipe: Scroll (Trackpad...
Enable pan gesture : unticked (found that enabling this often goes into pan mode when I am just moving my pointer around)
Limit zoom and scroll to prevent overflows : ticked (hoping that this would prevent weird zooming issue. I will describe what I am experiencing later this page)
Reverse mouse wheel direction for zoom :unticked
Mouse wheel zoom factor: 1.02

Things work as expected:

  • panning with two finger swipe
  • and the rest

Issue I am experiencing:

Often, when I am zooming in and out with two finger gestures, the view suddenly sets to some weird state and my drawing goes off the ruler.
The mouse point remains where it is.

Workaround:
Reset viewpoint with autozoom and navigate around.

Expected zoom behaviour:
I expect viewpoint to zoom in / out at where my mouse pointer is or at least the centre of current view point.

584QCAD (main)Bug ReportLowLibrary Items können unbrauchbar gemacht werden durch l...Assigned
0%
Task Description

Nach einigen Überraschungen ....

Es ist möglich Layer in nicht eingefügten oder unsichtbar geschalteten Library Items unbemerkt zu löschen ....

Fallbeispiel 1:
Ich arbeite an einer Zeichnung die u.a. den Layer “Gelbe Linie” benutzt.
Ich füge ein Library Item ein was auch einen Layer “Gelbe Linie” hat.
Ich lösche - aus welchen Gründen auch immer - in der Zeichnung das Library Item weil ich es erst später wieder verwenden will.
In der Blocklist ist es natürlich immer noch verfügbar.
In der Zeichnung lösche ich den Layer “Gelbe Linie” da ich diesen nicht brauche brauche - habe aber natürlich nicht im Kopf welche Layer in meinen Blocks verwendet wurden.
Nach einiger Zeit will ich den Block (den aus der Library) wieder einfügen - dieser ist nun aber unbrauchbar da der Inhalt welcher auf dem Layer “gelbe Linie” war fehlt.
Das Library Item neu aus Library laden um das bereits existierende zu reparieren scheitert da das erste nicht überschrieben werden kann. Ich muss den ersten Block löschen um den neuen benutzen zu können.

Fallbeispiel 2:
Da das selbe (löschen der Layer) auch passieren kann bei unsichtbar geschalteten Blöcken kann es dazu führen das ich zig bereits positionierte Blöcke zerstöre und neu platzieren muss um meine Zeichnung zu reparieren.

Fallbeispiel 3:
Ich sehe in meiner Zeichnung einen Layer “Gelbe Linie”. Weiß nicht was das ist - schalte alle Layer unsichtbar außer “Gelbe Linie”. Klicke auf “Auto Zoom” um zu sehen was den auf “Gelbe Linie” ist. Finde nichts = also leer! Lösche Layer “Gelbe Linie”. Der Layer wurde aber von einem im Moment nicht verwendeten Library Block verwendet. Es gibt keinen Hinweis das ich damit ein Library Item zerstören könnte ....

Lange Rede kurzer Sinn: Wäre es machbar/sinnvoll Layer in Blöcken nur löschen zu können wenn ich mich im Edit Modus der Blöcke befinde?

1339QCAD (main)Bug ReportLowLibrary Browser unstoppableAssigned
0%
Task Description

Hi,

Even with the Application Preference, Library Browser, NO Update on Start up,
the Libray Browser scans the directory, a proces that can’t be stopped or closed.

893QCAD (main)Bug ReportLowLibrary Browser - Edit Library Item - opens drawings al...Assigned
0%
Task Description

Library Browser - Edit Library Item - opens drawings always with grid.

- If I switch between opened drawings back and forth the grid will disappear ....
- If I switch the grid button between visible (it is already visible!) and invisible the grid is gone ....

Just Cosmetic ... ;-)

1691QCAD (main)Bug ReportVery LowIssue with Layouts after "File-Revert"Assigned
0%
Task Description

QCad 3.19.2 Professional, 64bit, Liux Mint

Case:
1. Open some saved drawing with viewport entities on layout block (paper space). Print Preview mode is “On” automatically.
2. After “File-Revert” drawing is reopened on layout block (paper space), but now Print Previw mode is “Off” .

For example can try on “flange.dxf”

498QCAD (main)Bug ReportLowissue importing from AutocadAssigned
0%
Task Description

There is an issue importing from Autocad:
lines and quotes (both arrows and text) appear too much big (see attachment).
I can fix quotes modifying dimensions in “current drawing preferences”, but lines are still too thick.
Autocad’s dxf are opened with right line thickness but wrong quotes.
Furthermore, Autocad opens Qcad’s dxf files showing wrong quotes.

714QCAD (main)Bug ReportLowIsometric view tool bar doesn`t remain ' docked'.Assigned
0%
Task Description

Win 7 - 64
Isometric view tool bar doesn`t remain ' docked’ when re-opening QCAD.

980QCAD (main)Bug ReportLowIsometric Projection / blocks / wrong layer are used in...Assigned
0%
Task Description

Isometric Projection used on a selection which contains blocks will mix up the layer affiliations.
No blocks - no problems ;-)

772QCAD (main)Bug ReportLowIsometric grid: toggle buttons not updatedAssigned
0%
Task Description

- Switch isometric grid off
- Switch isometric grid on using drawing preferences
- Tool buttons don’t reflect correct status

1427QCAD (main)Bug ReportLowInfo Tool / Polylinie Area (II)/ Preview brokenAssigned
0%
Task Description

Print “Command Line” and as “Add measurement to drawing” works as expected.

645QCAD (main)Bug ReportLowInch - Layerdata / Linewight still in mm ...Assigned
0%
Task Description

Drawing Unit is in “Inch” but the Layer Data (Line wight) is in “mm” ....

I like it ;-) ... but maybe I’m the only one :-(

1203dxflibBug ReportLowImages not saved (dxflib)Assigned
0%
Task Description

I am doing a bit of landscaping and using a (big) ortophoto as one of my layers in order to sanity-check on the ground measurements.

The layer contains a point and the image and nothing else.

The image is a 8MB file: “PNG image data, 4200 x 2980, 8-bit/color RGB, non-interlaced” and it is scaled to 210 coordinate units (meter) horizontally in the drawing.

With approx 50% probability the image disappears during Save, as see for instance in this diff of the DXF file:

      @@ -158699,28 +153057,6 @@ AcDbXrecord
        90
       6
         0
      -IMAGEDEF
      -  5
      -A1
      -100
      -AcDbRasterImageDef
      - 90
      -0
      -  1
      -/critter/HTV10/Ortofoto/ortofoto201502f.png
      - 10
      -210.0
      - 20
      -149.0
      - 11
      -1.0
      - 21
      -1.0
      -280
      -1
      -281
      -0
      -  0
       ENDSEC
         0
       EOF

The point in the same layer does not similarly disappear, the bug only seems to affect images.

I have seen this bug from version 3.7.5.0 to git as of yesterday (63e06c778926a803bdfbffdf27b8c24d41511072).

I have not been able to correlate the bug with anything.

Looking closer at the DXF file (attached), there seems to be some residuce of attempts to insert images in protected/invisible layers, so this may be some kind of refcounting issue.

(Any chance of getting FreeBSD into the “Operating System” field ?)

1972QCAD (main)Bug ReportLowHatch import fails for boundaries with many very small ...Assigned
0%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=6648

689QCAD (main)Bug ReportLowGrid spacing info not shownAssigned
0%
Task Description

OpenSuSE 12.2: the grid info display is not displayed:
http://www.qcad.org/rsforum/viewtopic.php?f=32&t=2178&view=unread#unread

1969QCAD (main)Bug ReportLowfont name not saving correctlyAssigned
0%
Task Description

0
STYLE

5

31D
330
239
100
AcDbSymbolTableRecord
100
AcDbTextStyleTableRecord

2

textstyle11
70

   0

40
0.0
41
1.0
50
0.0
71

   0

42
0.2

3

CASTELAR.TTF

4

1001
ACAD
1000
Castellar
1071

      0
1923QCAD (main)Bug ReportVery LowFaulty rendering Polylines with Global/Local Widths and...Assigned
0%
Task Description

Win7pro 32bit Qcad 3.23.0

Andrew,
The Arc segments of Polylines with Global or any Local Width render faulty where Global Z or any of the arc’s local Z is not zero.

In the attached drawing setting the Global Z of the inner poly to 5,10,...

The setting of Z to not zero affects the radius of the projected arc and not the bulging of the poly.
It also affects the projected widths of the line inversely, but not by changing the widths properties.

Pritty rare combination! True.
Qcad is 2D native! True.

Flatten will resolve this.

It is not a purely visual rendering fault, the poly will explode as such.

Maybe similar flaw as with uneven scaling blocks with arcs.
https://qcad.org/rsforum/viewtopic.php?f=8&t=5566#p20703

Regards

1765QCAD (main)Bug ReportVery LowErrors with polyline offsetAssigned
0%
1 Task Description

Win 7 32 bit QCAD 3.20.1

Ofsset of a base-line with arcs results in massive ammount of errors.
Most of them occur as a cluster of very tiny segments and are part of the offset. (zoom far in at the red circles)
Mostly they occur where the offsetted arcs should merely be trimmend pairwise.
Some occur as detached entities or as detached strings of entities very near the offset (strings not documented).
Spooks occur at opposite site when base-line is not closed.
360° curls can occur with R = Offset.
Null-entities may occur (not documented, hard to find and not able to copy).

The base-line is checked and sound and has mixed tangentially or not tangentially connected arcs.
Offsetting the mother base-line of the base in the file has similar effect but not all and/or different ones.
Also encountered with offseting polys from fonts.
Used to define pocket paths for CNC.
Detected because the CNC driver will not accept Self-crossers, Null-entities or open ends depending on the settings.

Work arround is to explode and select small entities but this does not solves the issues.
1) Choosing the tolerance large enough will detect small segments that should stay.
2) Recombining will generate new ones at the place where the main segments remain crossed.
Cleaning up the paths is a daunting process with some thousand segments for several offsets.

I assume this has an infuence on the CAM part of QCAD too unless the offset method is different.

976dxflibBug ReportLowDXF import errors related to hatches, textsAssigned
0%
Task Description

See:
http://www.qcad.org/rsforum/posting.php?mode=reply&f=30&t=2677

1008QCAD (main)Bug ReportLowDXF (dxflib) compat issuesAssigned
0%
Task Description

Git head as well as 3.4.5 (trial), both with dxflib 3.3.4.0.

Start up QCAD, (with existing or new configuration, doesn’t seem to matter), “Save as” the completely empty drawing, choose “R15 (dxflib)” on Pro (only this one is available on community), save drawing.

Fire up AutoCAD 2000, try to load the empty drawing just saved.

Result:

DXF read error
Error in APPID Table
DXF read error on line 941.
Invalid or incomplete DXF input -- drawing discarded.

Problem not present when a completely empty drawing saved using Teigha in R15 format is opened (ie. it just results in an empty drawing in AutoCAD 2000). Problem is also not present when saving an existing drawing with Pro (trial) with Teigha and opening it in AutoCAD 2000. Problem does present when trying to open a dxflib-saved drawing in AutoCAD 2000.

Empty drawings created with both dxflib 3.3.4.0 in QCAD Pro 3.4.5 trial and Teigha whatever in QCAD Pro trial 3.4.5 are attached. (Community Git 135fd0 is identical to Pro - same dxflib version.)

1960dwg2pdfBug ReportLowdwg2pdf command failAssigned
0%
Task Description

Good afternoon, I found a bug.

Source file: B5.dwg.

Command line: .\dwg2pdf.bat -f -a -recompute-dim -ltscale=1 -font-substitution Standard GBK path

After I used the command, the message “Warning: standard font not found” occured. And B5.pdf is not found.
Convert is fail.

1958dwg2pdfBug ReportLowDraw rectangle as ellipseAssigned
0%
Task Description

Good afternoon, I found a bug.

Original file: 006–【武汉会展中心店】一层合用前室.dwg

Converted file: 006–【武汉会展中心店】一层合用前室.pdf

Bug description file: problem5.png

As you see, all the rectangle fills are drawed as ellipse.

756QCAD (main)Bug ReportLowDisplay problem in the Text "Character Map" ...Assigned
0%
1 Task Description

XP/32

Go to:
Text → Special Characters → Others → “Character Map” pops up.
Adjust Zoom to 100% = display problem (not enough space for the single character.

1967QCAD/CAMBug ReportLowDevelopment snapshot: Toolpath generator problemAssigned
0%
Task Description

Hallo Andrew,

I had updated QCAD/CAM to 3.23.0.2 and I am confronted with a major bug in the toolpath generator.

Showing tasks 1 - 50 of 382 Page 1 of 81 - 2 - 3 - 4 - 5 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing