QCAD Bugtracker

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category QCAD/CAM
  • Assigned To
    Andrew
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 3.24.0
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: QCAD Bugtracker
Opened by Husky - 08.01.2020
Last edited by Andrew - 08.01.2020

FS#2025 - Set Nesting Quantity shows wrong quantity

If I set “Set Nesting Quantity” to e.g. 5 it will remember this number within the session.
If I need to check which number I’ve used last time there is no way to find the actual used value - it will show me always 1.
If I restart QCAD/CAM the value is completely lost and the nesting tool tries to fit in as much as possible into the sheet - regardless that the quantity number still shows one.

It would be nice to have a remember function even after restarting QCAD/CAM and have some kind of possibility to see the last used value.

Closed by  Andrew
08.01.2020 10:02
Reason for closing:  Not a bug
Admin
Andrew commented on 08.01.2020 10:02

If the file is saved after setting the quantity, the quantity should be remembered.

The quantity is a custom property added to the selected entities. You can see it using the property editor. If a part consists of multiple entities with different quantities, the result is undefined (one of the quantities is used for the whole part).

The nesting quantity dialog will not show the quantity of the selection as this can vary (one selected entity might have a quantity of "1", another a quantity of "100" yet another no quantity at all).

If the problem persists, please attach the file, thanks.

Husky commented on 08.01.2020 21:10

Ouch - I missed the custom property. Sorry for that!
And saving it within the dxf/dwg makes sense - I was looking to have it saved within the ini what now makes not anymore sense to me.

Thanks - I leaned something! ;-)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing