QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask Type  ascSeveritySummaryStatusProgress
 356 QCAD (main)Bug ReportHigh Javascript exception: any time user double clicks on te ...Closed
100%
Task Description

Javascript exception

Any time user double clicks on text, an exception is raised in the following script:

/qcad-3.0.0-rc1-prof-linux/scripts/Draw/Text/TextDialog/TextDialog.js

Fix is to comment out the line

      //bug.... simpleText.checked = textDataIn.isSimple();
 406 QCAD (main)Bug ReportHigh QCAD Version 3 RC2 .exe does`nt run  Closed
100%
Task Description

Hi Andrew

I uninstalled QCAD 3 RC1 first then installed V3-RC2 seems to install ok but when I run qcad.exe it complains everytime that qcad.exe has stopped working!

Running on Windows 7 - 64bit

Regards

Clive

 797 QCAD (main)Bug ReportHigh QCAD hanging after loading working file Closed
100%
Task Description

I have the german Version of QCAD 3.0.0.
After starting QCAD I load my current work file (an architecture one).
After loading I get two working Areas in QCAD and after a while the complete Software QCAD (only QCAD) is hanging. It is not possible to close the QCAD SW with the task Manager of Windows 7. Only to log out helps to Close or remove the running SW. The attachment Shows a Screen copy. The view is when you see through milky glasses to QCAD.

I bought this SW a few days ago and then this happened. I have spend a lot of time to generate my Project and now this.

Is there any one who knows what the Problem is?
Is that a Problem of thw QCAD SW or can be the problem my current work file (generated with QCAD on my Notebook). Note, Problem happens on my work Station. I have started to work on my Notebook, but i found out that the Screen is to small to work with QCAD. So i moved the SW to my work Station. (Both working with Windows 7) This to get more Details abou the handling and whathappens before.

Would be great to get a quick Response or better a working solution for my Problem. When you need more details please let me know.

[Edited by Admin for profanity]

 799 QCAD (main)Bug ReportHigh Detect duplicates not working properly Closed
100%
Task Description

Windows 7-64
3.0.9
Detect duplicates tool not working properly.
Selecting this tool causes program to lag endlessly and malfunctions.
To reproduce bug:
1. Select all entities.
2. Select duplicates tool.
3. Nothing happens.
4. Select duplicate tool again and...bug!

 900 QCAD (main)Bug ReportHigh Using text in 3.1.2 freezes QCAD Closed
100%
Task Description

Placing text in a drawing using 3.2.1 causes the application to freeze.
Please see topic:
http://www.qcad.org/rsforum/viewtopic.php?f=33&p=8355#p8355

 904 QCAD (main)Bug ReportHigh Crash when inserting some blocks from part library Closed
100%
Task Description

Tested on Linux Mint-64
Inserting some exsisting blocks or newly user created blocks makes QCAD quit!
Permissions were checked and also tested by submitting new blocks to new folder...but problem remains.
See related topic:
http://www.qcad.org/rsforum/viewtopic.php?f=33&p=8387#p8387

 395 QCAD (main)Bug ReportMedium wrong text origin when pasting scaled text and graphics Closed
100%
Task Description

Text origins are not properly scaled when pasting text and graphics at a scale other than 1:1

 518 QCAD (main)Bug ReportMedium Unable to use Library browser properly in RC4 Closed
100%
Task Description

Hi Andrew

In Ubuntu 11.10 and Windows 7 everything so far is working ok in QCAD apart from the Library browser!

1.In Win 7-64 I can run the browser and make a new folder, but when I try to set the permissions/open the folder - browser crashes.

2.In ubuntu 11.10 I first uninstalled RC2 then installed RC4. QCAD program runs ok but this time when I try to open up the browser (not a new folder)I get an error message stating that I do not have permissions to open the first file (vehicle -I think!)in RC2? If I select OK in the warning window the warning just keeps on repeating the same message for the next and subsequent files until I quit it.

 653 QCAD (main)Bug ReportMedium crash on some file operations may be Qt related Closed
100%
Task Description

On file open selection from main menu or on output to PDF Qcad crashes

error:

I/O error : No such file or directory
/usr/share/mime/inode/directory.xml:1: parser error : Extra content at the end of the document

 727 QCAD (main)Bug ReportMedium 100% CPU Usage with 3.0 Final Version. Closed
100%
Task Description

I am continuing my testing on version 3.0 Final.

I noticed that, with 3.0 Final open, the service “syslogd” (on OSX Leopard PPC) does get CPU consumption up to 100%, making the machine unusable.

This has never happened with the RC2 version.

It’s possible to have a copy of RC2 while they investigated the problem? Unfortunately I have not kept a copy.

 1243 QCAD (main)Bug ReportMedium Printing / PDF Export: points offset Closed
100%
Task Description

Hi !
im’ trying the 3.9.6 base version, and i have found a problem in printing/exporting..

To replicate the bug:
Try to draw a simple form, for ex a circle, and draw a center of this circle using POINT function.

Now if you make a print preview, then CENTER the circle in the page and try to export to pdf or print, the circle and the POINT (center) are ofsetted !!

i have try to make the same operation with 3.9.5 and i have no problem !!!

 1347 QCAD (main)Bug ReportMedium Point style bug. Closed
100%
Task Description

Hi !
i have find another strangeware about points.. if you set a different point style in program options, on the display the style is correct, but when you try to print or export the drawing, the points are printed as default “point” (little black circle).

 416 QCAD (main)Bug ReportLow Line weights and types are unclear in property editor i ...Closed
100%
Task Description

In V3RC3 (on Windows 7 -64)

In property editor lineweights and line types choices are unclear, e.g 0.00mm is reading as ... (3 dots only)

Also the lineweights are reading as m not mm!

Line types are very unclear too!

Regards

Clive

 451 QCAD (main)Bug ReportLow No Help function at all now Closed
100%
Task Description

Nothing happens at all when clicking on Help!

Used to open before with limited info but now nothing.

3 RC3 - Win 7 -64

 457 QCAD (main)Bug ReportLow Print page set up! Closed
100%
Task Description

Windows 7 - 64

Via - edit>drawing preferences or Application preferences>print page set up, it seems to make no difference setting the page orientation to either “Portrait” or “landscape” because when you go to print preview the set up you previously set doesn`t overide and set the orientation “set buttons” in print preview, so you have to manually set the orientation for the page you want to print from here (in print preview) regardless of the previously “preferenced” set up.

regards

Clive

 460 QCAD (main)Bug ReportLow doubleclick/select truetype font problems Closed
100%
Task Description

truetype fonts are more difficult to use than regular fonts. The do not select easily.

 481 QCAD (main)Bug ReportLow data points display as either a dot (.) or a plus sign  ...Closed
100%
Task Description

data points display as either a dot (.) or a plus sign (+) on output to pdf or printer. There appears to be no constancy or control over the behaviour. Any way it could be forced to behave like Qcad-2 (i.e. line-weight controlled dot (.) ???

 489 QCAD (main)Bug ReportLow Application Preferences - Show Crosshairs not work. Closed
100%
Task Description

In the “Preferences Panel” → “Graphics View” the checkbox “Show Crosshairs” not work. If it’s checked or unchecked the result is the same.

 504 QCAD (main)Bug ReportLow Poor results from offsetting a Spline in RC 2/3 Closed
100%
Task Description

Offsetting a Spline, after exploding and converting to a polyline produces a poor result!

1. Version 2.2 - no problems for using polyline Tools > offset for splines - after exploding them and creating a polyline from the segments! The results were acceptable!

2. Version 3 RC3 or 2 (Ubuntu) - the resultant offset of the Spline was unacceptable in Version 3 RC2/3 and only 50% of the offset was created!

 522 QCAD (main)Bug ReportLow  View > toolbars is only accessible by right clicking. Closed
100%
Task Description

Andrew

In Windows 7-64, the view > toolbar options are only available by ‘right clicking’ in the main menu somewhere. They are not included in the view ‘drop down’ menu!

 581 QCAD (main)Bug ReportLow Unit sizes in 'metric' templates misleading - showing a ...Closed
100%
Task Description

Windows 7 -64

In the metric templates the unit size shown in the preview is showing as ‘Inch’ instead of millimeter. probably just a ‘typo’ mistake here as in reality when you open up a ‘metric’ template they are indeed measuring in millimeters!

 629 QCAD (main)Bug ReportLow Viewports - not retaining positions? Closed
100%
Task Description

in Win 7-64

Hi Andrew
when I set up my default choice of viewports - say ‘Two vertical’, they do not retain either the initial starting position or indeed the position I leave them in when I reopen a drawing. On opening a new/previous drawing - always one of the viewports is at ‘almost’ full extents!
I then have to manually re-position my viewports to suit.

Is this normal behavior happening here?
It would be good if a drawing opened with persistent viewport positions held, possibly this option could be added to the ‘Layout’ Viewports dialog window?

*Out of interest, when you introduce an isometric grid in the future - will it be possible to set up a ‘Three:Right’ layout view for example and have all three viewports showing different planes - Top, Front and South East?

Thanks

Clive

 655 QCAD (main)Bug ReportLow  Changing Minimal grid spacing option (px) - proves no ...Closed
100%
Task Description

Changing the Minimal grid spacing (px) proves non effective, in that - it does not reduce the number of steps to to reach target view!

Tested and agreed on Win 7 -64

See Topics:

http://www.ribbonsoft.com/rsforum/viewtopic.php?f=31&p=6691#p6691

and related - http://www.ribbonsoft.com/rsforum/viewtopic.php?f=32&p=6694#p6694

 660 QCAD (main)Bug ReportLow Active Tool - 'tool bar' doesn `t stay redocked  Closed
100%
Task Description

The Active Tool tool bar doesn`t stay re-docked in QCAD 3 Final.
Please see topic:
http://www.ribbonsoft.com/rsforum/viewtopic.php?f=32&t=2108

665QCAD (main)Bug ReportLowPossible printing error on Linux fedora 16?Assigned
0%
Task Description

On behalf of et76
Possible printing error using Linux 16 - needs further testing!
Please see topic: http://www.ribbonsoft.com/rsforum/viewtopic.php?f=12&t=2119

Au nom de et76
Erreur d’impression possible en utilisant Linux 16 - a besoin d’autres tests!
S’il vous plaĆ®t voir le sujet: http://www.ribbonsoft.com/rsforum/viewtopic.php?f=12&t=2119

700QCAD (main)Bug ReportLowSaved 'hatched' block loses hatching when using isometr...Assigned
0%
Task Description

Hatched block loses hatching when using isometric projection tool:
See -http://www.qcad.org/rsforum/viewtopic.php?f=32&p=7063#p7063

When manipulating a saved hatched block with the isometric tool it loses the hatching unless the block is exploded.

Is this normal behaviour here? or a bug?

 709 QCAD (main)Bug ReportLow Move/copy MV - GUI -button (on docked tool bar) not wor ...Closed
100%
Task Description

Windows 7 - 64
To reproduce:
1.Select entity.
2.Using a ‘docked’ Modify tool bar, click on the Move/Copy button.
3.Unable to move cross hairs to snap properly to a reference point.

* No problems with this from either - the Menu > Modify > Move/Copy or the Main CAD tools > Modification tools or from using keycode MV!
Only from a ‘docked’ modify tool bar.

 710 QCAD (main)Bug ReportLow snapshot 3.0.3 - input fields showing ' Expression is e ...Closed
100%
Task Description

Windows 7 -64
snapshot 3.0.3 - tool input fields showing ' Expression is empty ' , even after inputting values.

714QCAD (main)Bug ReportLowIsometric view tool bar doesn`t remain ' docked'.Assigned
0%
Task Description

Win 7 - 64
Isometric view tool bar doesn`t remain ' docked’ when re-opening QCAD.

 718 QCAD (main)Bug ReportLow 3.0.5 -snap / info feedback problems Closed
100%
Task Description

In 3.0.5 using windows 7-64 and windows vista.
After selecting to use any drafting tool - either arc, circle or ellipse, polyline etc. there are problems with defining the second snap point onwards whether using auto snap or any of the snap tools,the info feedback i.e. End or Middle etc... is flickering or none at all.

Test:
1.Center, Point.
2.Define center.
3.Hard to define point, flickering occurs on graphics feedback for label.

I`m guessing this is another Graphic display problem here.

 723 QCAD (main)Bug ReportLow Hatch "Solid Fill" no saved. Closed
100%
Task Description

In the attached drawing (top figure) I created an hatch “Solid Fill”. I have saved, reopen and the “Solid Fill” is not present!

No problem (bottom figure) with other types of hatch.

It’s possible to have a workaround? Is urgent for terminate work.

Thank You.

 726 QCAD (main)Bug ReportLow Unable to save the windows layout. Closed
100%
Task Description

I decided to go from version 3.0 RC2 to version 3.0 Final.

I opened the program and I tried to customize the layout of the various toolbars and panels “Layer”, “Blocks”, etc..

On the next reboot all settings are lost and QCAD presents itself as image attached.

How can I fix?

754QCAD (main)Bug ReportLowAdding or removing additional viewports - gives unwante...Assigned
0%
Task Description

Windows 7-64
3.0.7
When adding or removing additional viewports,an extra unnecessary window of the viewport is created.

 768 QCAD (main)Bug ReportLow Polyline > Delete segments between two nodes not workin ...Closed
100%
Task Description

Windows 7 - 64
3.0.8
Polyline > Delete segments between two nodes not working.

 785 QCAD (main)Bug ReportLow Hatch at scale 1/10 not completed on 500 mm x 500 mm s ...Closed
100%
Task Description

Windows 7-64
3.0.8

I’ve not been able to hatch a simple Brick pattern at a scale of 1/10 on anything larger that 500 mm x 500 mm.

*Scale of 1:1 works fine
*Scale of 1/10 works fine on Squares 400 mm x 400 mm or less!

To reproduce:
1. Draw square of 500 x 500 mm.
2. Select and execute Hatch command using Brick pattern (but I suspect the result will be the same with any pattern).
3. Result in selection states a Hatch but no hatch is present!

Please see attached image:

794QCAD (main)Bug ReportLowApplying Solid grid lines - not workingAssigned
50%
Task Description

Windows
3.0.8
Application preferences > Graphics View > Appearance - Solid grid lines doesn’t change anything?

 795 QCAD (main)Bug ReportLow Render circular arcs precisely - tool query Closed
100%
Task Description

Although in my re-testing of this tool with 3.0.8 everything seemed fine I have since noticed that it only seems to work for line-weights of 0.5 mm and larger!
using a line weight of 0.00 produces the original non precise result.

Is this expected behaviour or is something still not quite right for this?

see topic:
http://www.qcad.org/rsforum/viewtopic.php?f=33&p=7684&sid=6121271d19c37dd6454644eacb4d33c4#p7684

 806 QCAD (main)Bug ReportLow File - Print , not working Closed
100%
Task Description

Windows 7-64

Selecting print from Main menu > File > Print - not working.

Print function only working from selecting the Print icon button from within the Print preview stage!

 808 QCAD (main)Bug ReportLow Strange 'jumpy' behavior when closing drawing windows. Closed
100%
Task Description

Test case:

In Windows, set up say 2 or 3 new blank drawings.Then close them down one by one and notice the behavior when closing these drawing windows down!

 810 QCAD (main)Bug ReportLow Polyline - Simplify, icon missing Closed
100%
Task Description

windows 7-64
3.1 beta

Polyline - Simplify option, the icon is missing.

The tool still functions as expected.

 820 QCAD (main)Bug ReportLow 3.1 beta - No reference manual found Closed
100%
Task Description

Windows 7-64

3.1 beta - No reference manual found.

 830 QCAD (main)Bug ReportLow multiple menu entries Closed
100%
Task Description

win 7-64, QCAD 3.1
Multiple menu entries ?
see related topic:http://www.qcad.org/rsforum/viewtopic.php?f=33&p=8031#p8031

 837 QCAD (main)Bug ReportLow error when checking for updates in 3.1.2 Closed
100%
Task Description

error when checking for updates in 3.1.2

 854 QCAD (main)Bug ReportLow Main menu > Help > About dialog only opens once ! Closed
100%
Task Description

Windows 7-64
3.1.5

The ‘About’ dialog via the Help menu only opens once - QCAD restart needed to open again!

 857 QCAD (main)Bug ReportLow Breakout / Autotrim not working Closed
100%
Task Description

Windows 7-64

Please see attached a simple test to demonstrate the problem.

Breakout tool

1. When selecting the top half of the circle - the top half of the circle ‘breaks’ out as expected.
2. When selecting the bottom half of the circle - the whole circle disappears!

Autotrim tool

1. When selecting the top half of the circle - the trim seems to work.

2. When selecting the bottom half of the circle - no trim happens at all!

 874 QCAD (main)Bug ReportLow Spelling error in 3.2 for 3 Tangents (CT3) Closed
100%
Task Description

In the feedback info for 3 Tangents (CT3) there is a spelling error!

‘tree’ instead of Three is used.

 878 QCAD (main)Bug ReportLow Paste - Flip problem  Closed
100%
Task Description

Please see related topic:
http://www.qcad.org/rsforum/viewtopic.php?f=33&p=8292#p8292

879QCAD (main)Bug ReportLowAutosave function not working if file is opened directl...Assigned
0%
Task Description

If a file is opened by clicking on it in an open ZIP archive, autosave will not work.

Linux Mint -64

Autosave function not working, error warning given instead!

 896 QCAD (main)Bug ReportLow Lineweight problem Closed
100%
Task Description

Linux Mint - 64

I need to laser cut some dashed circles and in order to do this I need to change the lineweight to 0.00mm (this is the lineweight I use for all laser cutting), however when I do this the result I get is not acceptable.

Using a lineweight of 0.05 is fine but our laser cutters will only read a lineweight of 0.00mm.Normally I would use a linetype of continuous and would be no problem, but for this particular job I need to use the smallest Dash option here!
For now I can get around this problem but it would be good to be able to choose this lineweight and linetype choice at some stage.

 899 QCAD (main)Bug ReportLow (De-)Select Polygon - No Mode buttons/Icons showing Closed
100%
Task Description

Linux Mint -64

(De-)Select Polygon - No Mode buttons/Icons showing

Showing tasks 1 - 50 of 199 Page 1 of 41 - 2 - 3 - 4 -

Available keyboard shortcuts

Tasklist

Task Details

Task Editing