QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#530 - sporadic unwanted close of QCad

Attached to Project: QCAD
Opened by Stefan (stefan) - Friday, 30 March 2012, 18:04 GMT+1
Last edited by Andrew (andrew) - Friday, 06 April 2012, 16:54 GMT+1
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Ubuntu Linux
Severity Medium
Priority Normal
Reported Version 3 RC4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Using the move and scale tools, QCad sometimes (reason unknown so far) crashes in RC4 (never seen that in RC2).

This task depends upon

Closed by  Andrew (andrew)
Friday, 06 April 2012, 16:54 GMT+1
Reason for closing:  Fixed
Additional comments about closing:  Most likely fixed by disabling debugger (RC5)
Comment by Stefan (stefan) - Sunday, 01 April 2012, 17:29 GMT+1

on another machine (also running XUbuntu), copy+paste seems to work, but pressing ESC after successful insertion will instantly crash QCad RC4

Comment by Stefan (stefan) - Sunday, 01 April 2012, 21:46 GMT+1

same with line tool: sometimes pressing ESC multiple times will instantly crash RC4

Comment by Stefan (stefan) - Monday, 02 April 2012, 15:08 GMT+1

This is really weird. The behaviour is in no way reproducible and sometimes occurs even on window-change (ctrl+tab). Normally, I would suspect my local RAM, but it occurs on two independent machines and only with RC4 (not with RC2).

Comment by Andrew (andrew) - Monday, 02 April 2012, 15:29 GMT+1

Yes, I am aware of these problems. It's caused by ECMAScripts being interrupted by system events.
These system events (focus in, focus out, mouse click, key press, etc) might trigger C++ or ECMAScript code that for example deletes an object the first script was relying on which leads to crashes.

This is most likely to happen when something is being terminated (e.g. after pressing Escape for tool termination or Ctrl-W for closing).

I've discovered today that switching off the Qt debugger (Preferences - Scripting) at the very least improves (if not fixes) the situation here.

I'd be extremely thankful for feedback of people who can confirm / deny that observation on their systems.

Thanks!

Comment by Stefan (stefan) - Monday, 02 April 2012, 21:00 GMT+1

40 minutes without this problem after disabling the debugger. :-) I will report after more testing (will take some time).

Comment by Andrew (andrew) - Monday, 02 April 2012, 21:13 GMT+1

Thanks for the report. Looks promising :)

It also starts to make some sense:
Scripts should normally not be interrupted by system events. But the debugger is notified whenever a function starts or ends (even if the debugger window is not shown). The debugger might allow for event processing during those notifications which I would consider to be a Qt bug.

Comment by Stefan (stefan) - Thursday, 05 April 2012, 14:07 GMT+1

I had some time to do some tests, no "unwanted close" with disabled debugger so far. :-) I will report after more tests.

Comment by Stefan (stefan) - Friday, 06 April 2012, 14:00 GMT+1

After several hours of testing, there was no unwanted close of QCad with disabled debugger. :-) (should the de-bugger ;-) introduce such a bug?)

Loading...