QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#518 - Unable to use Library browser properly in RC4

Attached to Project: QCAD
Opened by -- (clive) - Friday, 09 March 2012, 15:04 GMT+1
Last edited by Andrew (andrew) - Monday, 12 March 2012, 11:18 GMT+1
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Medium
Priority Normal
Reported Version 3 RC4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi Andrew

In Ubuntu 11.10 and Windows 7 everything so far is working ok in QCAD apart from the Library browser!

1.In Win 7-64 I can run the browser and make a new folder, but when I try to set the permissions/open the folder - browser crashes.

2.In ubuntu 11.10 I first uninstalled RC2 then installed RC4. QCAD program runs ok but this time when I try to open up the browser (not a new folder)I get an error message stating that I do not have permissions to open the first file (vehicle -I think!)in RC2? If I select OK in the warning window the warning just keeps on repeating the same message for the next and subsequent files until I quit it.

This task depends upon

Closed by  Andrew (andrew)
Monday, 12 March 2012, 11:18 GMT+1
Reason for closing:  Fixed
Comment by Andrew (andrew) - Friday, 09 March 2012, 18:05 GMT+1

Thanks for the report.

1. Problem seems to be triggered when adding and subsequently accessing folders while the library browser is running. Two files with a fix are attached:

 scripts/Tools/LibraryBrowser/db/DirectoryPeer.js
 scripts/Tools/LibraryBrowser/LibraryBrowser.js

2. Not sure I understand this correctly. When you try to start the QCAD Library Browser, what is the exact error message? What is the connection to RC2 at this point?

Thanks.

Comment by -- (clive) - Friday, 09 March 2012, 19:56 GMT+1

Andrew

At the moment I`m trying to get the Library browser working first in Ubuntu. So far I have determined that the path to the library in the library browser was set to RC2, I have now changed that to RC4- but now when I start the library browser it just starts the script debugger?

Now I don`t know whats happening!

Comment by -- (clive) - Friday, 09 March 2012, 20:03 GMT+1

Not sure if this helps?

Welcome to the Qt Script debugger.
Debugger commands start with a . (period).
Any other input will be evaluated by the script interpreter.
Type ".help" for help.

Debugger invoked from /home/clive/opt/qcad-3.0.0-rc4-prof-linux/scripts/library.js, line 46.
46 debugger;

Comment by Andrew (andrew) - Friday, 09 March 2012, 21:04 GMT+1

There seems to be an inconsistency between the QCAD binary and the scripts and resources that are being used.

It looks like the old QCAD binary is being started (RC2) instead of RC4. It then tries to use the scripts from RC4 which fails of course.

Please make sure that you start QCAD 3 RC4 from its installation directory:
cd /home/clive/opt/qcad-3.0.0-rc4-prof-linux
./qcad

You may also want to try to start the library browser directly to check if that works:
./qcad -app-id QCADLibraryBrowser -enable-xdata -autostart scripts/Tools/LibraryBrowser/launch.js

Comment by -- (clive) - Saturday, 10 March 2012, 11:06 GMT+1

Thanks Andrew

I followed your advice and with a little bit of playing about all is OK now!

Regards

Clive

Loading...