QCAD Bugtracker

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category QCAD (main)
  • Assigned To
    Andrew
  • Operating System Windows 7
  • Severity High
  • Priority Very Low
  • Reported Version 3 RC1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: QCAD Bugtracker
Opened by -- - 26.11.2011
Last edited by Andrew - 29.11.2011

FS#406 - QCAD Version 3 RC2 .exe does`nt run

Hi Andrew

I uninstalled QCAD 3 RC1 first then installed V3-RC2 seems to install ok but when I run qcad.exe it complains everytime that qcad.exe has stopped working!

Running on Windows 7 - 64bit

Regards

Clive

Closed by  Andrew
29.11.2011 23:26
Reason for closing:  Fixed
Additional comments about closing:  

Release: QCAD 3 RC3 for Windows

Husky commented on 27.11.2011 09:02

I have the same problem under XP/32bit except that I kept 3RC1 and installed 3RC2 in a new subdirectory.

During program start:
"qcad.exe hat ein Problem festgestellt und muss beendet werden"

Problemsignatur:
AppName: qcad.exe AppVer: 0.0.0.0 ModName: qtcore4.dll
ModVer: 4.7.3.0 Offset: 000e7ea3

-- commented on 27.11.2011 14:00

Thanks Husky

I have installed 3RC2 to a new subdirectory as you suggested and all is working fine now!

Regards

Clive

Admin
Andrew commented on 27.11.2011 19:09

Sometimes reproducible. Seems to be caused partly by stored value in Appearance/DockappWindows.

Changing in autostart.js

appWin.readSettings();
appWin.show();

to

appWin.show();
appWin.readSettings();

seems to fix it.
Possibly a Qt bug.

An RC2b package with the above fix will be available shortly.

Admin
Andrew commented on 27.11.2011 19:24

A potential fix is now online as RC2b. Please let me know if it does not work.

Husky commented on 27.11.2011 21:35

Nope - also RC2b doesn't work on my machine. Still a problem with the qtcore4.dll

Admin
Andrew commented on 27.11.2011 21:49

Please attach your QCAD.ini file:
C:\Documents and Settings\username\Application Data\RibbonSoft\QCAD3.ini

Where 'username' is your user (login) name. The exact path might depend on your system.

Bitte QCAD.ini Datei anhaengen:
C:\Documents and Settings\username\Application Data\RibbonSoft\QCAD3.ini

Wo 'username' Ihr Benutzername ist. Der Pfad kann von System zu System unterschiedlich sein.

Husky commented on 27.11.2011 22:53

Already in your inbox at info@ ......

Admin
Andrew commented on 28.11.2011 00:21

Thanks.

This seems to be related to user defined commands / shortcuts stored in the QCAD3.ini file.

At least deleting sections [Shortcuts] and [Commands] avoids the crash here.

I will continue to look into this.

Husky commented on 28.11.2011 07:19

Step 1:
After this hint from you I went back to RC1 and "restored to default" the two Shortcuts what I have changed in RC1. Note: I never deleted a Shortcut or Command.
Now RC2 is starting as expected - now crash!

Step 2:
I changed two shortcuts in RC2, saved the changes, restarted RC2 and was still able to start RC2 as normal.

It seems that you are on the right way ....

Jean-Jacques Brasse commented on 28.11.2011 09:32

installed RC2b. So far I did not notice the previous problems after editing the config file.
Thanks

-- commented on 28.11.2011 18:58

Hi Andrew

RC2b installed and working fine now - no problems.

regards

Clive

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing