QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1708 - Layer > Select Layer: add feedback

Attached to Project: QCAD
Opened by CVH (CVH) - Wednesday, 17 January 2018, 12:04 GMT+1
Last edited by Andrew (andrew) - Wednesday, 17 January 2018, 16:35 GMT+1
Task Type Feature Request
Category QCAD (main)
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version 3.19.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Win 7
Q-CAD 3.19.2

R-Click in Layer list
With a selection, selecting by Layer adds the Items on that Layer to the selection.
With a selection, deselecting by Layer subtracts the Items on that Layer from the selection.
This is not a bug in casu because this can be the intention of the function. Adding or Subtracting.

Intuitively ‘selecting by Layer’ to retrict to that Layer solely has only the desired effect if no selection existed before.
Deselecting by Layer with no previous selection should mention there was none to start with.
Selecting by Layer from an empty Layer should mention that nothing is added.

Faults are prone to make.

Selecting a Layer uniquely would be an interesting additional feature.

Regards

This task depends upon

Closed by  Andrew (andrew)
Wednesday, 17 January 2018, 16:35 GMT+1
Reason for closing:  Implemented
Comment by Andrew (andrew) - Wednesday, 17 January 2018, 12:43 GMT+1

Changed to a feature request to add feedback.

Comment by Andrew (andrew) - Wednesday, 17 January 2018, 16:34 GMT+1
Selecting a Layer uniquely would be an interesting additional feature.

This can be easily achieved using Select > Deselect All, Layer > Select Layer.

Comment by CVH (CVH) - Wednesday, 17 January 2018, 22:35 GMT+1
This can be easily achieved using Select > Deselect All, Layer > Select Layer. <

That is 4 clicks and a screen away from de R-click on the Layer List.
But this method will indisputable select solely the items on the Layer.

Intuitively it Fails:
All the functions of the R-click list act uniquely on 1 Layer except those that mention 'all'.

Selecting: One tend to see it as an action on the Items of 1 Layer only . [Selecting only the Items of 1 Layer].
Deselecting on the other hand is clearly deselecting only the Items of 1 Layer and removing them from the Selection.
It should be mentioned: 'Select Layer' Adds; 'Deselect Layer' Subtracts.

Informational it Fails:
Deselecting by Layer with no previous selection should mention there was none to start with.
Selecting by Layer from an empty Layer should mention that nothing is added.

Loading...