QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1661 - Viewport rotation issue

Attached to Project: QCAD
Opened by Husky (Husky) - Sunday, 12 November 2017, 09:14 GMT+1
Last edited by Andrew (andrew) - Sunday, 12 November 2017, 12:10 GMT+1
Task Type Bug Report
Category QCAD (main)
Status Closed
Assigned To Andrew (andrew)
Operating System Windows 10
Severity Low
Priority Normal
Reported Version 3.19.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Case:

1. Launch Add Viewport, adjust setting for scale and rotation, determine Viewport - QCAD will switch to a Layout Block
= scale and rotation works as expected.

2. Launch Add Viewport, determine Viewport - QCAD will switch to a Layout Block,

change scale setting = works as expected on view and frame,

change rotation = works on view BUT NOT ON VIEWPORT FRAME.

This task depends upon

Closed by  Andrew (andrew)
Sunday, 12 November 2017, 12:10 GMT+1
Reason for closing:  Not a bug
Additional comments about closing:  Expected behaviour (see comment).
Comment by Andrew (andrew) - Sunday, 12 November 2017, 12:10 GMT+1

Unfortunately, viewports cannot be rotated in that way. Only the contents of the viewport can be rotated. The viewport frame (clipping) is always orthogonal.

Comment by Husky (Husky) - Sunday, 12 November 2017, 19:34 GMT+1

Hmmm - I'm confused. It works in Model Space but the same Option (Scale, rotate) doesn't works in Layout Block?

Example with a 0.5 scale and 90 degree rotation

Comment by Andrew (andrew) - Sunday, 12 November 2017, 21:14 GMT+1

A viewport in QCAD allows for its contents to be displayed at a rotation angle. The contents of a viewport is the model space or part of it.

If you change the rotation angle in model space (while defining the area to be shown), you can see that the frame rotates, so that you can see exactly which part of the drawing will be displayed in the viewport and where it will be clipped.

If you change the rotation angle in paper space, the angle still applies to the model space shown. However, the viewport frame has already been defined at that stage and since it stays always orthogonal, you can now see the contents of the viewport being rotated.

Arguably, it usually makes more sense to adjust the angle in model space, while defining the part to be shown. But there are situations in which adjusting the angle in paper space can be useful as well.

Comment by Husky (Husky) - Monday, 13 November 2017, 04:39 GMT+1

Ok, thanks for this additional explanation. Understood.

"If you change the rotation angle in model space (while defining the area to be shown), you can see that the frame rotates ..."

This is what caused the confusion! You CAN'T see the rotation when a 90 degree rotation is used in Model Space. 0, 90, 180 and 270 degree behave visually on the same way. Every other rotation angle is clear noticeable.

Thanks!

Loading...