QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1653 - Dimension font configuration only loaded if drawing contains dimension entity

Attached to Project: QCAD
Opened by Husky (Husky) - Thursday, 09 November 2017, 01:02 GMT+1
Last edited by Andrew (andrew) - Thursday, 09 November 2017, 14:19 GMT+1
Task Type Bug Report
Category QCAD (main)
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version 3.19.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This bugs me since a long time but I wasn’t able to reproduce it ..... till now!

My Dim Label font for new drawings (Application Preferences) is set to “Helvetica-Bold” Basically it was working just fine for new drawings but from time to time, after saving and reopen my drawing, the font was lost and replaced by “Standard”. No idea why!

Today I was playing with the new QCAD Feature “Default Template” and learned that I loose all the time my preselected font. QCAD ignores that my Template “Drawing Preferences” and also the “Application Preferences” are set to “Helvetica-Bold”. It will be replaced by “Standard”. Annoying! :-(

Ok, question was why it doesn’t happened with all drawings, all the time?
After many tests ....
The “old” blank Template opens with the correct font setting. If I use a Dim in the drawing and save it everything works as expected.
If I save the drawing without a Dim in it then the preselected Font will be replaced by “Standard”. It happens also if I delete all Dims in a so far proper working drawing - save and reopen it leads to the same issue. The Font will be replaced by “Standard”.

The new feature “your own Default Template” will not work regarding the Dim Label font in any cases - the template itself needs at least one Dim in the drawing to keep the desired Font.

This task depends upon

Closed by  Andrew (andrew)
Thursday, 09 November 2017, 14:19 GMT+1
Reason for closing:  Fixed
Comment by Husky (Husky) - Thursday, 09 November 2017, 01:11 GMT+1

@Andrew - please edit the title - I can't do it by myself.

Loading...