QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1642 - Selection Filter / Line / Continuous

Attached to Project: QCAD
Opened by Husky (Husky) - Thursday, 05 October 2017, 23:07 GMT+1
Last edited by Andrew (andrew) - Thursday, 05 October 2017, 23:36 GMT+1
Task Type Bug Report
Category QCAD (main)
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version 3.18.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The Selection Filter doesn’t works proper with a Line / Continuous combination. Example drawing has Linetype by Layer and not by Layer

Filter
Entity type: Line
Property: Linetype
Comparison: = (is)
Value: Continuous

... doesn’t finds what I have ask for.
Husky-2017.10.05-04.png

Filter
Entity type: Line
Property: Linetype
Comparison: ≠ (is not)
Value: Continuous

... finds more than that what I have ask for.
Husky-2017.10.05-03

This task depends upon

Closed by  Andrew (andrew)
Thursday, 05 October 2017, 23:36 GMT+1
Reason for closing:  Not a bug
Comment by Andrew (andrew) - Thursday, 05 October 2017, 23:36 GMT+1

This is expected behavior. None of the lines in the file provided have their line type set to "Continuous". Note that "By Layer" is not the same as "Continuous", not even if the layer's linetype happens to be "Continuous". If you add a line and set it's linetype to "Continuous", it will be selected.

Loading...