QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1582 - Layer > Show all Layers / Hide all Layers: unexpected outcome when frozen column not shown

Attached to Project: QCAD
Opened by Husky (Husky) - Thursday, 18 May 2017, 21:19 GMT+1
Last edited by Andrew (andrew) - Friday, 19 May 2017, 08:39 GMT+1
Task Type Bug Report
Category QCAD (main)
Status Closed
Assigned To Andrew (andrew)
Operating System Windows 10
Severity Low
Priority Normal
Reported Version 3.17.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,

if I create in a new drawing a layer list and use the Show all Layers / Hide all Layers function everything works as expected.

If I hide one or more Layers individually and directly in the Layer List (click on the Eye) I can’t make them visible with the Show all Layer function. It looks like individual hidden Layer are protected with a higher priority.

If I load an “old” drawing all individual settings for a hidden Layer are with a higher priority than Show all Layers. If I click every single Eye for each Layer to make them visible then I’m again able to toggle the visibility for all Layer in once.

This task depends upon

Closed by  Andrew (andrew)
Friday, 19 May 2017, 08:39 GMT+1
Reason for closing:  Fixed
Comment by Andrew (andrew) - Thursday, 18 May 2017, 21:46 GMT+1

Note that starting with QCAD 3.17.0, layers can be off or frozen (to increase compatibility with other DXF/DWG products).
You might want to enabled the frozen column (Edit > Application Preferences > Widgets > Layer List > Show frozen column) to check if a layer in a loaded drawing is frozen.

I will see if I can improve this for users with the frozen column off (default).

Comment by Andrew (andrew) - Thursday, 18 May 2017, 21:49 GMT+1 Comment by Husky (Husky) - Thursday, 18 May 2017, 22:10 GMT+1

Thanks for this tip - unfortunately it makes it much more confusing to me ...

My report was based on a Layer List without this frozen status column visible.

If I turn this column visible it works like you described it.
If I turn it off (all Layer unfrozen!) it behaves like my report.

Why will the visibility / invisibility of this column in the Layer List change the functionality?

Comment by Andrew (andrew) - Thursday, 18 May 2017, 22:15 GMT+1

Did you have a chance to try the above proposed patch for Layer.js?

Frozen and Off are two different layer states which both influence the layer visibility. Unfortunately, they are rather complex by design, even more so if layer 0 is involved.

If the frozen column is not shown, ideally, things should work as before (this might not be 100% possible to achieve though).

Comment by Husky (Husky) - Thursday, 18 May 2017, 22:22 GMT+1

I use right now the new script and it looks good! Works like expected.

I will switch back for testing to the old script - give me a few minutes ....

Comment by Husky (Husky) - Thursday, 18 May 2017, 22:26 GMT+1

« If the frozen column is not shown, ideally, things should work as before »

Nope - the old script works different when this column is shown or not.

Loading...